summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-imagick/pecl-imagick-3.1.2-r1.ebuild')
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.1.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.1.2-r1.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.1.2-r1.ebuild
new file mode 100644
index 000000000000..c3c71f450cec
--- /dev/null
+++ b/dev-php/pecl-imagick/pecl-imagick-3.1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DOCS="TODO"
+
+MY_PV="${PV/rc/RC}"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP wrapper for the ImageMagick library"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples"
+
+# -openmp needed wrt bug 547922 and upstream https://github.com/mkoppanen/imagick#openmp
+DEPEND=">=media-gfx/imagemagick-6.2.4:=[-openmp]"
+RDEPEND="${DEPEND}"
+
+my_conf="--with-imagick=/usr"