summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-imagick/pecl-imagick-3.4.4.ebuild')
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.4.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.4.4.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.4.4.ebuild
new file mode 100644
index 000000000000..3e6ae079e530
--- /dev/null
+++ b/dev-php/pecl-imagick/pecl-imagick-3.4.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="imagick"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP wrapper for the ImageMagick library"
+HOMEPAGE="https://pecl.php.net/imagick https://github.com/mkoppanen/imagick"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples test"
+
+# imagemagick[-openmp] is needed wrt bug 547922 and upstream
+# https://github.com/mkoppanen/imagick#openmp
+RDEPEND=">=media-gfx/imagemagick-6.2.4:=[-openmp]"
+DEPEND="${RDEPEND}
+ test? ( >=media-gfx/imagemagick-6.2.4:=[jpeg,png,truetype] )"
+
+PHP_EXT_ECONF_ARGS="--with-imagick=${EPREFIX%/}/usr"