summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/php-redmine-api/php-redmine-api-1.5.16.ebuild')
-rw-r--r--dev-php/php-redmine-api/php-redmine-api-1.5.16.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/php-redmine-api/php-redmine-api-1.5.16.ebuild b/dev-php/php-redmine-api/php-redmine-api-1.5.16.ebuild
new file mode 100644
index 000000000000..8325488aea33
--- /dev/null
+++ b/dev-php/php-redmine-api/php-redmine-api-1.5.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A simple, object-oriented, PHP Redmine API client"
+HOMEPAGE="https://github.com/kbsali/${PN}"
+SRC_URI="https://github.com/kbsali/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*[curl,json,simplexml]"
+BDEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-4 )"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r lib
+
+ dodoc example.php README.markdown
+}
+
+src_test() {
+ phpunit || die "test suite failed"
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in a script, require('${PN}/lib/autoload.php'), and then"
+ elog "use the Redmine\\Client class normally. Most of the examples in the"
+ elog "documentation should work without modification."
+}