summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/php-redmine-api')
-rw-r--r--dev-php/php-redmine-api/Manifest1
-rw-r--r--dev-php/php-redmine-api/php-redmine-api-1.5.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-php/php-redmine-api/Manifest b/dev-php/php-redmine-api/Manifest
index 85edf3d2398e..1e860643a0e4 100644
--- a/dev-php/php-redmine-api/Manifest
+++ b/dev-php/php-redmine-api/Manifest
@@ -1 +1,2 @@
DIST php-redmine-api-1.5.2.tar.gz 31126 SHA256 466a83703997793b0bc783c0b61aa83824c690e233a5278db2b9e7bd31108a43 SHA512 cf39a154edc3994d380901ef20f6d1f26dc948a45664c819fd98225d86e6aef440518fa70896ca72149ed7ed2a163df856f33f6e9b3b36858573f118b22f10e5 WHIRLPOOL afe4eba58769ab17e18f321bea887e45e1853343afa125c67b79c260e4875841cc321e541e54fcd73541f1c56ae14c2cbffa67834965ce25ac8fc948f94575bd
+DIST php-redmine-api-1.5.6.tar.gz 36400 SHA256 1dddbc1ead5c9d26659ba205847be258d4697ff4f5d80a9c6d6310c37bc9b63b SHA512 3f2990d46d5ee8529b21d119489d9431a303f61c7126303f794b489d92d0ccf2e24cad321e7040dade5ab956d696f84084a89ce391ea4fb39cf137c103a93ad9 WHIRLPOOL 37943c104bc2f84f61bef7f0b9d3880079d1521724dfc0f1634dcef48d37076ca95029f9fc4f3909d6c78d21c707d4505f4ece64c8d9697c83b7d08dc23dd865
diff --git a/dev-php/php-redmine-api/php-redmine-api-1.5.6.ebuild b/dev-php/php-redmine-api/php-redmine-api-1.5.6.ebuild
new file mode 100644
index 000000000000..fda65b20b7ec
--- /dev/null
+++ b/dev-php/php-redmine-api/php-redmine-api-1.5.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A simple, object-oriented, PHP Redmine API client"
+HOMEPAGE="https://github.com/kbsali/${PN}"
+SRC_URI="https://github.com/kbsali/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*[curl,json,simplexml]"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-4 )"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r lib
+
+ dodoc example.php README.markdown
+}
+
+src_test() {
+ phpunit || die "test suite failed"
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in a script, require('${PN}/lib/autoload.php'), and then"
+ elog "use the Redmine\\Client class normally. Most of the examples in the"
+ elog "documentation should work without modification."
+}