summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phpunit/phpunit-4.3.1.ebuild')
-rw-r--r--dev-php/phpunit/phpunit-4.3.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-php/phpunit/phpunit-4.3.1.ebuild b/dev-php/phpunit/phpunit-4.3.1.ebuild
new file mode 100644
index 000000000000..b1d013e47d0c
--- /dev/null
+++ b/dev-php/phpunit/phpunit-4.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A PHP Unit Testing framework"
+HOMEPAGE="http://phpunit.de"
+
+PHPUNIT_PHAR="${P}.phar"
+
+SRC_URI="https://phar.phpunit.de/${PHPUNIT_PHAR}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86"
+IUSE=""
+
+DEPEND="dev-lang/php:*[phar,xml]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ return
+}
+
+src_install() {
+ insinto /usr/share/php/phpunit
+ insopts -m755
+ newins "${DISTDIR}"/${PHPUNIT_PHAR} phpunit.phar
+ dosym /usr/share/php/phpunit/phpunit.phar /usr/bin/phpunit
+}
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}