summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/spdx-licenses/spdx-licenses-1.5.0.ebuild')
-rw-r--r--dev-php/spdx-licenses/spdx-licenses-1.5.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/spdx-licenses/spdx-licenses-1.5.0.ebuild b/dev-php/spdx-licenses/spdx-licenses-1.5.0.ebuild
new file mode 100644
index 000000000000..8b9ab0e5b041
--- /dev/null
+++ b/dev-php/spdx-licenses/spdx-licenses-1.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for working with and validating SPDX licenses"
+HOMEPAGE="https://github.com/composer/spdx-licenses"
+SRC_URI="https://github.com/composer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto "/usr/share/php/Composer/res"
+ doins -r res/.
+
+ insinto "/usr/share/php/Composer/Spdx"
+ doins -r src/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}