summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/xcache')
-rw-r--r--dev-php/xcache/Manifest1
-rw-r--r--dev-php/xcache/metadata.xml15
-rw-r--r--dev-php/xcache/xcache-3.2.0-r2.ebuild62
3 files changed, 0 insertions, 78 deletions
diff --git a/dev-php/xcache/Manifest b/dev-php/xcache/Manifest
deleted file mode 100644
index 9d2ec3691d7f..000000000000
--- a/dev-php/xcache/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST xcache-3.2.0.tar.bz2 148392 BLAKE2B f366b3b3563f6e150851bc2b2cea099abb29c778bebbbd69d83ec1d7f6dd4f808d28e082c945ffee49b303af34a9c43a0f9f1c61fb1072b57cc28d85bb2fa3c8 SHA512 9d7bec73ac941c8e38b2cda15af65044291adc0806b39586048943515d67656d64871bea4ea05b3dff76761ebed462db2d6ad0e489079291abc55313b1508946
diff --git a/dev-php/xcache/metadata.xml b/dev-php/xcache/metadata.xml
deleted file mode 100644
index c8185e7f2890..000000000000
--- a/dev-php/xcache/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
-
- <use>
- <flag name="coverage">
- Enable the coverager module (not recommended for
- production servers).
- </flag>
- </use>
-</pkgmetadata>
diff --git a/dev-php/xcache/xcache-3.2.0-r2.ebuild b/dev-php/xcache/xcache-3.2.0-r2.ebuild
deleted file mode 100644
index 64e55e43a542..000000000000
--- a/dev-php/xcache/xcache-3.2.0-r2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="xcache"
-PHP_EXT_SAPIS="apache2 cgi fpm"
-USE_PHP="php5-6"
-
-inherit php-ext-source-r3
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="coverage"
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="
- !dev-php/eaccelerator
- !dev-php/pecl-apc
- virtual/httpd-php:*
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-xcache=shared
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- $(use_enable coverage xcache-coverager) \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder )
-
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- php-ext-source-r3_src_install
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins lib/Decompiler.class.php
-
- # Install the admin interface somewhere where it can be
- # copied/symlinked into a document root.
- insinto "/usr/share/${PN}"
- doins -r htdocs
-}
-
-pkg_postinst() {
- elog "The lib/Decompiler.class.php file shipped with this release"
- elog "was installed into ${PHP_EXT_SHARED_DIR}. The htdocs/ admin"
- elog "interface directory can be found under ${EPREFIX}/usr/share/${PN}."
-}