summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/beanstalkc')
-rw-r--r--dev-python/beanstalkc/Manifest1
-rw-r--r--dev-python/beanstalkc/beanstalkc-0.4.0-r1.ebuild22
-rw-r--r--dev-python/beanstalkc/beanstalkc-0.4.0.ebuild22
-rw-r--r--dev-python/beanstalkc/metadata.xml9
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/beanstalkc/Manifest b/dev-python/beanstalkc/Manifest
new file mode 100644
index 000000000000..3bf9c0088d11
--- /dev/null
+++ b/dev-python/beanstalkc/Manifest
@@ -0,0 +1 @@
+DIST beanstalkc-0.4.0.tar.gz 13921 SHA256 98978e57797320146f4b233286d9a02f65d20bad0168424118839fc608085280 SHA512 30485aed4036549c524982bbabe5a27af5fe6f0547175622019b4469fc1fef32d013cbef5e38a1928ab92a3acf6aba9bc7607c3e8e9f2f3c6f65631d39471a7b WHIRLPOOL ca43ca379ed87046f926185d43caeab8f29ffb4388bdc0e6184cf59f98016537e68f8f63188199c895b45d9da39df59cdf34b39372faffbc5499300c5f919a2d
diff --git a/dev-python/beanstalkc/beanstalkc-0.4.0-r1.ebuild b/dev-python/beanstalkc/beanstalkc-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..42a49dda47dd
--- /dev/null
+++ b/dev-python/beanstalkc/beanstalkc-0.4.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple beanstalkd client library"
+HOMEPAGE="http://github.com/earl/beanstalkc http://pypi.python.org/pypi/beanstalkc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/beanstalkc/beanstalkc-0.4.0.ebuild b/dev-python/beanstalkc/beanstalkc-0.4.0.ebuild
new file mode 100644
index 000000000000..921323ed6a71
--- /dev/null
+++ b/dev-python/beanstalkc/beanstalkc-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple beanstalkd client library"
+HOMEPAGE="http://github.com/earl/beanstalkc http://pypi.python.org/pypi/beanstalkc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/beanstalkc/metadata.xml b/dev-python/beanstalkc/metadata.xml
new file mode 100644
index 000000000000..5dc4ad459118
--- /dev/null
+++ b/dev-python/beanstalkc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">beanstalkc</remote-id>
+ <remote-id type="github">earl/beanstalkc</remote-id>
+ </upstream>
+</pkgmetadata>