summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fonttools/fonttools-2.5.ebuild')
-rw-r--r--dev-python/fonttools/fonttools-2.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/fonttools/fonttools-2.5.ebuild b/dev-python/fonttools/fonttools-2.5.ebuild
new file mode 100644
index 000000000000..2c5409582d66
--- /dev/null
+++ b/dev-python/fonttools/fonttools-2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/behdad/fonttools/"
+SRC_URI="https://github.com/behdad/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/numpy-1.0.2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ DOCS=( README.md Doc/{changes.txt,install.txt} )
+ HTML_DOCS=( Doc/documentation.html )
+ distutils-r1_python_install_all
+}