summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gst-python/gst-python-1.14.1-r1.ebuild')
-rw-r--r--dev-python/gst-python/gst-python-1.14.1-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/gst-python/gst-python-1.14.1-r1.ebuild b/dev-python/gst-python/gst-python-1.14.1-r1.ebuild
index 569085071b25..e3f7b6251a8d 100644
--- a/dev-python/gst-python/gst-python-1.14.1-r1.ebuild
+++ b/dev-python/gst-python/gst-python-1.14.1-r1.ebuild
@@ -40,18 +40,18 @@ src_compile() {
# Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
# separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
compile_gst() {
- emake -C common || die "emake common failed"
- emake -C gi || die "emake gi failed"
- emake -C testsuite || die "emake testsuite failed"
+ emake -C common
+ emake -C gi
+ emake -C testsuite
}
python_foreach_impl run_in_build_dir compile_gst
}
src_install() {
install_gst() {
- emake DESTDIR="${D}" install -C common || die "emake install common failed"
- emake DESTDIR="${D}" install -C gi || die "emake install gi failed"
- emake DESTDIR="${D}" install -C testsuite || die "emake install testsuite failed"
+ emake DESTDIR="${D}" install -C common
+ emake DESTDIR="${D}" install -C gi
+ emake DESTDIR="${D}" install -C testsuite
}
python_foreach_impl run_in_build_dir install_gst
prune_libtool_files --modules
@@ -60,7 +60,7 @@ src_install() {
src_test() {
test_gst() {
- emake check -C testsuite || die "emake check failed"
+ emake check -C testsuite
}
python_foreach_impl run_in_build_dir default
}