summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonext/jsonext-0.4.2-r1.ebuild')
-rw-r--r--dev-python/jsonext/jsonext-0.4.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jsonext/jsonext-0.4.2-r1.ebuild b/dev-python/jsonext/jsonext-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..2a7b50f6a05d
--- /dev/null
+++ b/dev-python/jsonext/jsonext-0.4.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Well-structured helpers for serializing commonly encountered structures to JSON"
+HOMEPAGE="
+ https://github.com/mbr/jsonext/
+ https://pypi.org/project/jsonext/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86"
+
+RDEPEND="
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --doctest-modules jsonext
+}