summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonxs/jsonxs-0.6-r1.ebuild')
-rw-r--r--dev-python/jsonxs/jsonxs-0.6-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/jsonxs/jsonxs-0.6-r1.ebuild b/dev-python/jsonxs/jsonxs-0.6-r1.ebuild
new file mode 100644
index 000000000000..39aeaffc85bd
--- /dev/null
+++ b/dev-python/jsonxs/jsonxs-0.6-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Get/set values in JSON and Python datastructures"
+HOMEPAGE="https://github.com/fboender/jsonxs"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+python_test() {
+ "${EPYTHON}" jsonxs/jsonxs.py -v || die "Tests failed with ${EPYTHON}"
+}