summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libnacl/libnacl-1.4.3.ebuild')
-rw-r--r--dev-python/libnacl/libnacl-1.4.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/libnacl/libnacl-1.4.3.ebuild b/dev-python/libnacl/libnacl-1.4.3.ebuild
new file mode 100644
index 000000000000..b04448e38ccc
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.4.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="https://libnacl.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/libsodium"
+
+python_test() {
+ ${EPYTHON} tests/runtests.py || die
+}