summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild')
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..2398f2c70957
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python module used for monitoring filesystems events"
+HOMEPAGE="
+ https://pypi.org/project/pyinotify/
+ https://github.com/seb-m/pyinotify/
+"
+SRC_URI="
+ https://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+PATCHES=(
+ "${FILESDIR}/${P}-py312.patch"
+)
+
+python_install_all() {
+ if use examples; then
+ dodoc -r python3/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}