summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypam/pypam-0.5.0-r8.ebuild')
-rw-r--r--dev-python/pypam/pypam-0.5.0-r8.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/pypam/pypam-0.5.0-r8.ebuild b/dev-python/pypam/pypam-0.5.0-r8.ebuild
deleted file mode 100644
index 9d2b524b2b96..000000000000
--- a/dev-python/pypam/pypam-0.5.0-r8.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-MY_P="PyPAM-${PV}"
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python Bindings for PAM (Pluggable Authentication Modules)"
-HOMEPAGE="http://www.pangalactic.org/PyPAM"
-SRC_URI="http://www.pangalactic.org/PyPAM/${MY_P}.tar.gz
- https://distfiles.gentoo.org/distfiles/ad/PyPAM-0.5.0.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-IUSE=""
-
-DEPEND=">=sys-libs/pam-0.64"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS examples/pamtest.py )
-
-PATCHES=(
- # Pull patches from fedora.
- "${FILESDIR}/PyPAM-${PV}-dealloc.patch"
- "${FILESDIR}/PyPAM-${PV}-nofree.patch"
- "${FILESDIR}/PyPAM-${PV}-memory-errors.patch"
- "${FILESDIR}/PyPAM-${PV}-return-value.patch"
- "${FILESDIR}/PyPAM-python3-support.patch"
- # Fix a missing include.
- "${FILESDIR}/${P}-stricter.patch"
-)
-
-python_test() {
- "${EPYTHON}" tests/PamTest.py || die
-}