summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.45.ebuild')
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.45.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.45.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.45.ebuild
new file mode 100644
index 000000000000..ba103b806bbd
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.45.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"