summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-1.12.11.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.12.11.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.12.11.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.11.ebuild
new file mode 100644
index 000000000000..7a7a68e62676
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.11.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"