summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/dbf/dbf-2.0.8.ebuild')
-rw-r--r--dev-ruby/dbf/dbf-2.0.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/dbf/dbf-2.0.8.ebuild b/dev-ruby/dbf/dbf-2.0.8.ebuild
new file mode 100644
index 000000000000..e83928603a61
--- /dev/null
+++ b/dev-ruby/dbf/dbf-2.0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/*"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="a small fast library for reading dBase, xBase, Clipper and FoxPro
+database files"
+HOMEPAGE="https://github.com/infused/dbf"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/fastercsv/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}