summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/kpeg')
-rw-r--r--dev-ruby/kpeg/kpeg-1.1.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-ruby/kpeg/kpeg-1.1.0.ebuild b/dev-ruby/kpeg/kpeg-1.1.0.ebuild
index 77c9124d8843..98ea6e99fa50 100644
--- a/dev-ruby/kpeg/kpeg-1.1.0.ebuild
+++ b/dev-ruby/kpeg/kpeg-1.1.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
@@ -14,8 +14,10 @@ HOMEPAGE="https://github.com/evanphx/kpeg"
LICENSE="MIT"
SLOT="1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+ ${RUBY} -Ilib:test:. -e 'gem "minitest", "~>5.0"; Dir["test/test_*.rb"].each{|f| require f}' || die
}