summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/method_source/method_source-0.8.2-r3.ebuild')
-rw-r--r--dev-ruby/method_source/method_source-0.8.2-r3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/method_source/method_source-0.8.2-r3.ebuild b/dev-ruby/method_source/method_source-0.8.2-r3.ebuild
new file mode 100644
index 000000000000..21a313d35dec
--- /dev/null
+++ b/dev-ruby/method_source/method_source-0.8.2-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the source code for a method"
+HOMEPAGE="https://github.com/banister/method_source"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
+
+each_ruby_test() {
+ ${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
+}