summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mocha/mocha-1.1.0.ebuild')
-rw-r--r--dev-ruby/mocha/mocha-1.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/mocha/mocha-1.1.0.ebuild b/dev-ruby/mocha/mocha-1.1.0.ebuild
new file mode 100644
index 000000000000..37cb9fb79b91
--- /dev/null
+++ b/dev-ruby/mocha/mocha-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC="yardoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for mocking and stubbing using a syntax like that of JMock, and SchMock"
+HOMEPAGE="http://gofreerange.com/mocha/docs/"
+
+LICENSE="MIT"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+ruby_add_rdepend "dev-ruby/introspection" # introspection ~> 0.0.1
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+}
+
+each_ruby_test() {
+ export MOCHA_NO_DOCS=true
+ each_fakegem_test
+}