summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ox/ox-2.4.9.ebuild')
-rw-r--r--dev-ruby/ox/ox-2.4.9.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-ruby/ox/ox-2.4.9.ebuild b/dev-ruby/ox/ox-2.4.9.ebuild
deleted file mode 100644
index c465dfafee4b..000000000000
--- a/dev-ruby/ox/ox-2.4.9.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A fast XML parser and Object marshaller"
-HOMEPAGE="http://www.ohler.com/ox/ https://github.com/ohler55/ox"
-SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
-
-KEYWORDS="~amd64 ~ppc64 ~x86"
-SLOT="0"
-IUSE=""
-
-each_ruby_configure() {
- ${RUBY} -Cext/ox extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/ox
- cp ext/ox/ox$(get_modname) lib/ox/ || die
-}
-
-each_ruby_test() {
- ${RUBY} test/tests.rb || die
-}