summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pdf-core/pdf-core-0.5.0.ebuild')
-rw-r--r--dev-ruby/pdf-core/pdf-core-0.5.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild b/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild
new file mode 100644
index 000000000000..cef30fb379ac
--- /dev/null
+++ b/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements low level PDF features for Prawn"
+HOMEPAGE="http://github.com/prawnpdf/pdf-core/"
+
+LICENSE="|| ( Ruby GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1.1*
+ >=dev-ruby/pdf-reader-1.2 =dev-ruby/pdf-reader-1* )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
+}