summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/polyglot/polyglot-0.3.5.ebuild')
-rw-r--r--dev-ruby/polyglot/polyglot-0.3.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/polyglot/polyglot-0.3.5.ebuild b/dev-ruby/polyglot/polyglot-0.3.5.ebuild
new file mode 100644
index 000000000000..7c041689077f
--- /dev/null
+++ b/dev-ruby/polyglot/polyglot-0.3.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Polyglot provides support for fully-custom DSLs"
+HOMEPAGE="http://polyglot.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ # jruby has trouble parsing this metadata and there are no dependencies.
+ rm -f ../metadata || die
+}