summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/posix-spawn')
-rw-r--r--dev-ruby/posix-spawn/Manifest2
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.10.ebuild33
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.9.ebuild33
3 files changed, 0 insertions, 68 deletions
diff --git a/dev-ruby/posix-spawn/Manifest b/dev-ruby/posix-spawn/Manifest
index 9296258d81a6..355fe8e3cf9e 100644
--- a/dev-ruby/posix-spawn/Manifest
+++ b/dev-ruby/posix-spawn/Manifest
@@ -1,3 +1 @@
-DIST posix-spawn-0.3.10.gem 28672 SHA256 15440fbfe25cc188e08e64f3bb632592368db669c2a13c1a9d56d81d1bbf54a1 SHA512 231f908c65c5b6f142239dbe52687f53139461826f25819aed905c0b3251c341dcc98db398d2f3e2b55bc27b61975adca1a5ac3caaedc64d178e6bb8485d952c WHIRLPOOL 7d8769fdc6e389b12a53df20e1e7e3f695e9a35138e26b685cd1e37dd435320bbe07d387937fe87b1a45df6b309b7373d30fbaf2b350f75e0913e4fc77dd039d
DIST posix-spawn-0.3.11.gem 29696 SHA256 b932835dd6eb241b255ba51767b68a58299abbb0fb344cb874dcd23d57b75414 SHA512 a053d80b5f8fca5c70b7aa0799ca07b3fb24b6cbf8b8c04e302f0864e72597e0843a120608838ca71a413a24422e571f4d3422141b726177d360b892e914cbc3 WHIRLPOOL 61898240d9487f476aadff17f9e405b6850fd5c9e3096737c08a6c9ce07464090851810ea754744b199203451db46e540510928fd55ac3dbfa612192426875f9
-DIST posix-spawn-0.3.9.gem 28672 SHA256 634746d6f090c1b15d2f92fa90c5ed4868e59c8752ca56a5d83af8f79c0a5110 SHA512 3afd9e26f04e7fedda176b47b3b48be4eb55d5ad8aa38983060acbbae49ec515e925cf223d4700a98f1293a702782bf80cb7aea715c351b5ebdc42618ea2a605 WHIRLPOOL 15d647f6fd95486c85cc98f8e498e586f3ac0c1686a36041f3dd38b43de860f4231ba37a0126e4fd7fe3f39620271a20c0dbb742198226e75d47d8f26d67dcf6
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.10.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.10.ebuild
deleted file mode 100644
index c63a60344b2f..000000000000
--- a/dev-ruby/posix-spawn/posix-spawn-0.3.10.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
-KEYWORDS="~amd64"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
-
-inherit ruby-fakegem
-
-DESCRIPTION="The posix-spawn library aims to implement a subset of the Ruby 1.9 Process::spawn"
-HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
-
-LICENSE="MIT LGPL-2.1"
-SLOT="0"
-IUSE="test"
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext
- cp ext/*$(get_modname) lib/ || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
-}
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.9.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.9.ebuild
deleted file mode 100644
index 71f7d7ed4ed7..000000000000
--- a/dev-ruby/posix-spawn/posix-spawn-0.3.9.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
-KEYWORDS="~amd64"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
-
-inherit ruby-fakegem
-
-DESCRIPTION="The posix-spawn library aims to implement a subset of the Ruby 1.9 Process::spawn"
-HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
-
-LICENSE="MIT LGPL-2.1"
-SLOT="0"
-IUSE="test"
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext
- cp ext/*$(get_modname) lib/ || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S testrb test || die
-}