summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/racc/racc-1.4.9.ebuild')
-rw-r--r--dev-ruby/racc/racc-1.4.9.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/racc/racc-1.4.9.ebuild b/dev-ruby/racc/racc-1.4.9.ebuild
new file mode 100644
index 000000000000..d830e70422b0
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A LALR(1) parser generator for Ruby"
+HOMEPAGE="http://www.loveruby.net/en/racc.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+all_ruby_prepare() {
+ sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
+
+ # Avoid depending on rake-compiler since we don't use it to compile
+ # the extension.
+ sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
+ sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
+
+ # Avoid isolation since dependencies are not properly declared.
+ sed -i -e 's/, :isolate//' Rakefile || die
+}
+
+each_ruby_prepare() {
+ ${RUBY} -Cext/racc extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r rdoc
+
+ docinto examples
+ dodoc -r sample
+}