summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ttfunk/ttfunk-1.4.0.ebuild')
-rw-r--r--dev-ruby/ttfunk/ttfunk-1.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/ttfunk/ttfunk-1.4.0.ebuild b/dev-ruby/ttfunk/ttfunk-1.4.0.ebuild
new file mode 100644
index 000000000000..fbb1badece10
--- /dev/null
+++ b/dev-ruby/ttfunk/ttfunk-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A TrueType font parser written in pure ruby"
+HOMEPAGE="https://github.com/prawnpdf/ttfunk/"
+SRC_URI="https://github.com/prawnpdf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 Ruby )"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}