summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/min-cscope/min-cscope-16.1.0.ebuild')
-rw-r--r--dev-util/min-cscope/min-cscope-16.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/min-cscope/min-cscope-16.1.0.ebuild b/dev-util/min-cscope/min-cscope-16.1.0.ebuild
new file mode 100644
index 000000000000..075d2ae1486c
--- /dev/null
+++ b/dev-util/min-cscope/min-cscope-16.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://sourceforge.net/projects/kscope/"
+SRC_URI="mirror://sourceforge/kscope/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+S=${WORKDIR}/${PN}
+
+DOCS="AUTHORS README* TODO"
+
+src_prepare() {
+ echo 'INSTALL(TARGETS min-cscope RUNTIME DESTINATION bin)' \
+ >> src/CMakeLists.txt
+}
+
+src_configure() {
+ append-flags -I"${S}/sort"
+ cmake-utils_src_configure
+}