summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/premake/premake-4.3-r1.ebuild')
-rw-r--r--dev-util/premake/premake-4.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/premake/premake-4.3-r1.ebuild b/dev-util/premake/premake-4.3-r1.ebuild
new file mode 100644
index 000000000000..9d37258756ca
--- /dev/null
+++ b/dev-util/premake/premake-4.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator eutils
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="http://industriousone.com/premake"
+SRC_URI="mirror://sourceforge/premake/${P}-src.zip"
+
+LICENSE="BSD"
+SLOT=$(get_major_version)
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/archless.patch"
+}
+
+src_compile() {
+ emake -C build/gmake.unix/
+}
+
+src_install() {
+ dobin bin/release/premake4
+}