summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/sasm/sasm-9999.ebuild')
-rw-r--r--dev-util/sasm/sasm-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/sasm/sasm-9999.ebuild b/dev-util/sasm/sasm-9999.ebuild
new file mode 100644
index 000000000000..84d291de9ea7
--- /dev/null
+++ b/dev-util/sasm/sasm-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
+ SRC_URI=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Dman95/SASM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/SASM-${PV}"
+fi
+
+DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
+HOMEPAGE="http://dman95.github.io/SASM/"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+REPEND="${DEPEND}
+ dev-lang/nasm
+ sys-devel/gdb
+"