summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/squashdelta/squashdelta-0.1.ebuild')
-rw-r--r--dev-util/squashdelta/squashdelta-0.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/squashdelta/squashdelta-0.1.ebuild b/dev-util/squashdelta/squashdelta-0.1.ebuild
new file mode 100644
index 000000000000..93cd33b1bd39
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://bitbucket.org/mgorny/squashdelta/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ autotools-utils_src_configure
+}