summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/umockdev/umockdev-0.8.2.ebuild')
-rw-r--r--dev-util/umockdev/umockdev-0.8.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/umockdev/umockdev-0.8.2.ebuild b/dev-util/umockdev/umockdev-0.8.2.ebuild
new file mode 100644
index 000000000000..f29eedfc35de
--- /dev/null
+++ b/dev-util/umockdev/umockdev-0.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-any-r1 autotools-utils
+
+DESCRIPTION="Mock hardware devices for creating unit tests"
+HOMEPAGE="https://github.com/martinpitt/umockdev/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RDEPEND="virtual/libgudev:=
+ virtual/libudev:=
+ >=dev-libs/glib-2.32:2"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+RESTRICT="test"