summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/clion/Manifest1
-rw-r--r--dev-util/clion/clion-2019.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
index 8aa6bc1711cb..c0c364e448cb 100644
--- a/dev-util/clion/Manifest
+++ b/dev-util/clion/Manifest
@@ -1 +1,2 @@
DIST clion-2018.3.4.tar.gz 454682485 BLAKE2B 5e56fe7abf86b10c78b307c510ba22ef14fe73cd9504c3ab093e0677f9d7901fd446bccc1b464a88d40042c0b105ea0cc8a46e985e359407d75a73b875766a52 SHA512 ffe594b2df390cb41cd2c5629a1b8f9a80cf8463c05d22d43af2da3a8db73e9d52ebd70c15771b813c049299ce4b3a3765a4bd6f65fe59cbd904b3536f182d75
+DIST clion-2019.1.tar.gz 429061573 BLAKE2B 14c2227509fd4c24d09ca139ff9f58ab2be71ad249d8f8a09d615cdc1aa07e9d2e0be9618e795859f564b63705a34e61dc90f3de5a012ad8fdf9a2f8ba512c33 SHA512 5c919ad2ea87744e0b3488958e58a9f67d8a8dcfa6affd86f975842c9e562663464d73373c72ef8085cede8f16828342dc17e182e761c199936bffee2f398509
diff --git a/dev-util/clion/clion-2019.1.ebuild b/dev-util/clion/clion-2019.1.ebuild
new file mode 100644
index 000000000000..608e28eedd97
--- /dev/null
+++ b/dev-util/clion/clion-2019.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils
+
+DESCRIPTION="A complete toolset for C and C++ development"
+HOMEPAGE="https://www.jetbrains.com/clion"
+SRC_URI="https://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="IDEA
+ || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror splitdebug"
+IUSE="custom-jdk"
+
+# RDEPENDS may cause false positives in repoman.
+# clion requires cmake and gdb at runtime to build and debug C/C++ projects
+RDEPEND="
+ dev-util/cmake
+ sys-devel/gdb
+ !custom-jdk? ( virtual/jdk )"
+
+QA_PREBUILT="opt/${P}/*"
+
+src_prepare() {
+ default
+
+ local remove_me=(
+ bin/gdb/linux
+ bin/lldb/linux
+ bin/cmake
+ license/CMake*
+ )
+
+ use amd64 || remove_me+=( bin/fsnotifier64 )
+ use arm || remove_me+=( bin/fsnotifier-arm )
+ use x86 || remove_me+=( bin/fsnotifier )
+
+ use custom-jdk || remove_me+=( jre64 )
+
+ rm -rv "${remove_me[@]}" || die
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{clion.sh,clang/linux/clang{d,-tidy}}
+
+ if use amd64; then
+ fperms 755 "${dir}"/bin/fsnotifier64
+ fi
+ if use arm; then
+ fperms 755 "${dir}"/bin/fsnotifier-arm
+ fi
+ if use x86; then
+ fperms 755 "${dir}"/bin/fsnotifier
+ fi
+
+ if use custom-jdk; then
+ if [[ -d jre64 ]]; then
+ fperms 755 "${dir}"/jre64/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
+ fi
+ fi
+
+ make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+ newicon "bin/${PN}.svg" "${PN}.svg"
+ make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ dodir /usr/lib/sysctl.d/
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
+}