summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/monkey-bubble/files')
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch30
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch45
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-gnome-doc.patch38
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-noesound.patch19
4 files changed, 132 insertions, 0 deletions
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch
new file mode 100644
index 000000000000..1e8822d0f871
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch
@@ -0,0 +1,30 @@
+--- monkey-bubble-0.3.2/src/net/Makefile.am.orig
++++ monkey-bubble-0.3.2/src/net/Makefile.am
+@@ -28,10 +28,10 @@
+ monkey_srv_LDFLAGS =
+
+ monkey_srv_LDADD = \
+- $(MONKEY_SRV_LIBS) \
+ libmonkeynet.a \
+ ../monkey/libmonkey.a \
+- ../util/libmonkeyutil.a
++ ../util/libmonkeyutil.a \
++ $(MONKEY_SRV_LIBS) -lm
+
+ $(libmonkeynet_a_OBJECTS): $(marshal_sources)
+
+--- monkey-bubble-0.3.2/src/ui/Makefile.am.orig
++++ monkey-bubble-0.3.2/src/ui/Makefile.am
+@@ -50,10 +50,10 @@
+
+
+ monkey_bubble_LDADD = \
+- $(UI_LIBS) \
+ ../monkey/libmonkey.a \
+ ../view/libmonkeyview.a \
+ ../util/libmonkeyutil.a \
+ ../net/libmonkeynet.a \
+ ../audio/libmonkeyaudio.a \
+- ../input/libmbinput.a
++ ../input/libmbinput.a \
++ $(UI_LIBS) -lm
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch
new file mode 100644
index 000000000000..67109beff7f7
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch
@@ -0,0 +1,45 @@
+Index: monkey-bubble-0.4.0/src/net/message-handler.c
+===================================================================
+--- monkey-bubble-0.4.0.orig/src/net/message-handler.c
++++ monkey-bubble-0.4.0/src/net/message-handler.c
+@@ -28,7 +28,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <arpa/inet.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <sys/time.h>
+ #include <time.h>
+
+Index: monkey-bubble-0.4.0/src/net/simple-server.c
+===================================================================
+--- monkey-bubble-0.4.0.orig/src/net/simple-server.c
++++ monkey-bubble-0.4.0/src/net/simple-server.c
+@@ -31,13 +31,12 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <arpa/inet.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <sys/time.h>
+ #include <time.h>
+
+
+ #include <glib-object.h>
+-#include <glib.h>
+
+ #include "simple-server.h"
+ #include "message-handler.h"
+Index: monkey-bubble-0.4.0/src/ui/main.c
+===================================================================
+--- monkey-bubble-0.4.0.orig/src/ui/main.c
++++ monkey-bubble-0.4.0/src/ui/main.c
+@@ -15,7 +15,7 @@
+ #include <gtk/gtk.h>
+ #include <gst/gst.h>
+ #include <bonobo/bonobo-i18n.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <libgnomeui/gnome-ui-init.h>
+
+ #include <math.h>
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-gnome-doc.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-gnome-doc.patch
new file mode 100644
index 000000000000..801ae84d9bab
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-gnome-doc.patch
@@ -0,0 +1,38 @@
+--- help/C/monkey-bubble.xml
++++ help/C/monkey-bubble.xml
+@@ -23,7 +23,7 @@
+ <publishername>GNOME Documentation Project</publishername>
+ </publisher>
+ <authorgroup>
+- <author>
++ <author role="maintainer">
+ <firstname>Thomas</firstname>
+ <surname>Cataldo</surname>
+ <affiliation>
+@@ -55,6 +55,7 @@
+ manual, follow the directions in the
+ <ulink url="ghelp:gnome-feedback" type="help">GNOME Feedback Page</ulink>. </para>
+ </legalnotice>
++ <abstract role="description"><para>Monkey Bubble manual</para></abstract>
+ </articleinfo>
+
+ <indexterm>
+--- help/fr/monkey-bubble.xml
++++ help/fr/monkey-bubble.xml
+@@ -22,7 +22,7 @@
+ <publishername>Projet de documentation GNOME</publishername>
+ </publisher>
+ <authorgroup>
+- <author>
++ <author role="maintainer">
+ <firstname>Thomas</firstname>
+ <surname>Cataldo</surname>
+ <affiliation>
+@@ -47,6 +47,7 @@
+ <title>Votre avis</title>
+ <para>Pour signaler un probl&egrave;me ou faire une suggestion concernant l'application Monkey Bubble ou le pr&eacute;sent manuel, proc&eacute;dez comme indiqu&eacute;&agrave; la <ulink url="ghelp:gnome-feedback" type="help">GNOME Feedback Page</ulink>.</para>
+ </legalnotice>
++ <abstract role="description"><para>Monkey Bubble manual</para></abstract>
+ </articleinfo>
+
+ <indexterm>
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-noesound.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-noesound.patch
new file mode 100644
index 000000000000..be0a9a924a47
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-noesound.patch
@@ -0,0 +1,19 @@
+monkey-bubble-0.4.0: don't require the esd header.
+
+2010-07-12 Sven Herzberg
+2012-01-07 Martin von Gagern
+
+References:
+https://github.com/mquinson/monkey-bubble/commit/299623f8e6b0b6090e98
+https://bugs.gentoo.org/397997
+
+--- monkey-bubble-0.4.0.orig/src/ui/main.c
++++ monkey-bubble-0.4.0/src/ui/main.c
+@@ -11,7 +11,6 @@
+ #include "ui-main.h"
+ #include "input-manager.h"
+
+-#include <esd.h>
+ #include <gtk/gtk.h>
+ #include <gst/gst.h>
+ #include <bonobo/bonobo-i18n.h>