summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/openbubbles')
-rw-r--r--games-arcade/openbubbles/Manifest1
-rw-r--r--games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch20
-rw-r--r--games-arcade/openbubbles/metadata.xml19
-rw-r--r--games-arcade/openbubbles/openbubbles-1.2.ebuild28
4 files changed, 68 insertions, 0 deletions
diff --git a/games-arcade/openbubbles/Manifest b/games-arcade/openbubbles/Manifest
new file mode 100644
index 000000000000..aee64dc4e596
--- /dev/null
+++ b/games-arcade/openbubbles/Manifest
@@ -0,0 +1 @@
+DIST openbubbles-1.2.tar.bz2 1090220 SHA256 7d5d4633a4881559f475b0b9e3778d593f856dd1dbf0acf979b79852f8d63dbb SHA512 fe546f12e6d045cb37f4c9f88dd42fc627d614933525066bd3eb867e5d8732f2f23fe117ff1a444fc3c33d471ae51099c865d9082134e0e8a051ce8a3df58244 WHIRLPOOL fa988262a9a636800ec8bc0aa2ce3c9cb6cb35f5244c76ef1e50a10cfaf445d664435f022280aac8b90424754d08deb9e9d2187af174634072b0b438180da072
diff --git a/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch b/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch
new file mode 100644
index 000000000000..d511734da28f
--- /dev/null
+++ b/games-arcade/openbubbles/files/openbubbles-1.2-glibc2.10.patch
@@ -0,0 +1,20 @@
+--- src/BFont.cpp
++++ src/BFont.cpp
+@@ -319,7 +319,7 @@
+ int i = 0;
+
+ /* Calculate the space occupied by the text without spaces */
+- while ((p=strchr(&text[pos+1],SPACE)) != NULL) {
++ while ((p=strchr((char *)&text[pos+1],SPACE)) != NULL) {
+ i++;
+ pos = p - text;
+ }
+@@ -359,7 +359,7 @@
+ xpos=0;
+ pos = -1;
+ while ( spaces > 0 ) {
+- p = strstr(&text[pos+1]," ");
++ p = strstr((char *)&text[pos+1]," ");
+ strtmp = NULL;
+ strtmp = (char *) calloc ((p - &text[pos+1]) + 1,sizeof(char));
+ if (strtmp != NULL)
diff --git a/games-arcade/openbubbles/metadata.xml b/games-arcade/openbubbles/metadata.xml
new file mode 100644
index 000000000000..906d51d15057
--- /dev/null
+++ b/games-arcade/openbubbles/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+This is a clone of Evan Bailey's game Bubbles. Why did I reinvent the wheel? In
+this case, the wheel is made in Game Maker, so anyone who wants to do any
+serious programming would not be able to unless they A) ran Windows and B) ran a
+program that doesn't give the user very great power. OpenBubbles is written in
+C++ using SDL, so the programmer has some pretty powerful tools at his/her
+disposal; in addition, because SDL is cross-platform, OpenBubbles can be ported
+to any (major) platform, including Windows. Of course, I only run Unix, so I
+will only be producing Unix source code. Though it was a relatively minor issue,
+Evan's license is only semi-free because it doesn't permit commercial use of the
+source code. Now, you are free to make as much money as you want off of
+improvements of OpenBubbles (provided, of course, that you share them with me
+and everyone else under the GPL, too).
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/openbubbles/openbubbles-1.2.ebuild b/games-arcade/openbubbles/openbubbles-1.2.ebuild
new file mode 100644
index 000000000000..434c1926a151
--- /dev/null
+++ b/games-arcade/openbubbles/openbubbles-1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A clone of Evan Bailey's game Bubbles"
+HOMEPAGE="http://www.freewebs.com/lasindi/openbubbles/index.html"
+SRC_URI="http://www.freewebs.com/lasindi/openbubbles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-gfx"
+RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-glibc2.10.patch )
+
+src_install() {
+ default
+ newicon data/bubble.png ${PN}.png
+ make_desktop_entry ${PN} "OpenBubbles"
+ prepgamesdirs
+}