summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/pachi/pachi-1.0.ebuild')
-rw-r--r--games-arcade/pachi/pachi-1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-arcade/pachi/pachi-1.0.ebuild b/games-arcade/pachi/pachi-1.0.ebuild
new file mode 100644
index 000000000000..eb5f07833f36
--- /dev/null
+++ b/games-arcade/pachi/pachi-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="platform game inspired by games like Manic Miner and Jet Set Willy"
+HOMEPAGE="http://dragontech.sourceforge.net/index.php?main=pachi&lang=en"
+# Upstream doesn't version their releases.
+# (should be downloaded and re-compressed with tar -jcvf)
+#SRC_URI="mirror://sourceforge/dragontech/pachi_source.tgz"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[joystick,sound,video]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/Pachi
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-autotools.patch
+ rm -f missing
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon Tgfx/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Pachi /usr/share/pixmaps/${PN}.bmp
+ prepgamesdirs
+}