summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/stormbaancoureur/files/stormbaancoureur-2.1.6-gentoo.patch8
-rw-r--r--games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r1.ebuild44
2 files changed, 48 insertions, 4 deletions
diff --git a/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.6-gentoo.patch b/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.6-gentoo.patch
index 07413ecb5448..4523d677e9f8 100644
--- a/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.6-gentoo.patch
+++ b/games-sports/stormbaancoureur/files/stormbaancoureur-2.1.6-gentoo.patch
@@ -1,5 +1,5 @@
---- stormbaancoureur-2.1.6.orig/src-stormbaancoureur/Makefile
-+++ stormbaancoureur-2.1.6/src-stormbaancoureur/Makefile
+--- src-stormbaancoureur/Makefile
++++ src-stormbaancoureur/Makefile
@@ -5,21 +5,21 @@
GLPREFIX=/usr
PLIBPREFIX=/usr
@@ -89,8 +89,8 @@
debugrun: stormbaancoureur
PLODE_DATADIR=`pwd` gdb ./stormbaancoureur
---- stormbaancoureur-2.1.6.orig/src-stormbaancoureur/main.cxx
-+++ stormbaancoureur-2.1.6/src-stormbaancoureur/main.cxx
+--- src-stormbaancoureur/main.cxx
++++ src-stormbaancoureur/main.cxx
@@ -836,15 +836,7 @@
fprintf(stderr,"plib is (c) by Steve Baker\n");
fprintf(stderr,"OpenDE is (c) by Russel L. Smith\n");
diff --git a/games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r1.ebuild b/games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r1.ebuild
new file mode 100644
index 000000000000..08683c7a1a3b
--- /dev/null
+++ b/games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Simulated obstacle course for automobiles"
+HOMEPAGE="http://www.stolk.org/stormbaancoureur/"
+SRC_URI="http://www.stolk.org/stormbaancoureur/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-games/ode-0.8
+ media-libs/alsa-lib
+ media-libs/freeglut
+ >=media-libs/plib-1.8.4
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P}/src-${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ sed -ie "s:GENTOODIR:/usr/share/${PN}:" main.cxx || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r images/ models/ sounds/ shaders/
+ dodoc JOYSTICKS README TODO
+ make_desktop_entry ${PN} "Stormbaan Coureur"
+}