summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/atlas/atlas-0.5.1_beta_pre20160907.ebuild3
-rw-r--r--games-util/atlas/files/atlas-0.5.1_beta_pre20160907-jpeg-9.patch27
2 files changed, 29 insertions, 1 deletions
diff --git a/games-util/atlas/atlas-0.5.1_beta_pre20160907.ebuild b/games-util/atlas/atlas-0.5.1_beta_pre20160907.ebuild
index 5d915b192896..4fed6a08e4a1 100644
--- a/games-util/atlas/atlas-0.5.1_beta_pre20160907.ebuild
+++ b/games-util/atlas/atlas-0.5.1_beta_pre20160907.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,6 +40,7 @@ S=${WORKDIR}/${MY_P}
PATCHES=(
"${FILESDIR}/${P}-simgear-compilation.patch"
+ "${FILESDIR}/${P}-jpeg-9.patch"
)
src_prepare() {
diff --git a/games-util/atlas/files/atlas-0.5.1_beta_pre20160907-jpeg-9.patch b/games-util/atlas/files/atlas-0.5.1_beta_pre20160907-jpeg-9.patch
new file mode 100644
index 000000000000..639ff8217546
--- /dev/null
+++ b/games-util/atlas/files/atlas-0.5.1_beta_pre20160907-jpeg-9.patch
@@ -0,0 +1,27 @@
+Fix build with jpeg-9. Bug # 520908
+
+--- a/src/Image.cxx 2018-02-07 03:19:18.538699623 +0100
++++ b/src/Image.cxx 2018-02-07 03:20:15.105160934 +0100
+@@ -29,11 +29,12 @@
+
+ // Other libraries' include files
+ #include <png.h>
+-#include <jpeglib.h>
+
+ // Our project's include files
+ #include "misc.hxx"
+
++#include <jpeglib.h>
++
+ // This is a constant representing "Not an Elevation" - it is
+ // guaranteed to be less than any possible real elevation value.
+ static const float NanE = -std::numeric_limits<float>::max();
+@@ -266,7 +267,7 @@
+ cinfo.in_color_space = JCS_RGB;
+
+ jpeg_set_defaults(&cinfo);
+- jpeg_set_quality(&cinfo, quality, true);
++ jpeg_set_quality(&cinfo, quality, TRUE);
+
+ jpeg_start_compress(&cinfo, TRUE);
+