summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/sogo/Manifest1
-rw-r--r--gnustep-apps/sogo/metadata.xml3
-rw-r--r--gnustep-apps/sogo/sogo-4.0.7.ebuild108
3 files changed, 112 insertions, 0 deletions
diff --git a/gnustep-apps/sogo/Manifest b/gnustep-apps/sogo/Manifest
index 53edb62bc220..bf31fa483b72 100644
--- a/gnustep-apps/sogo/Manifest
+++ b/gnustep-apps/sogo/Manifest
@@ -1,2 +1,3 @@
DIST sogo-3.2.10.tar.gz 32528115 BLAKE2B 7543f2165ed20026f00adfac7697fe6bc0e54f06b3c2ccb99fbfe0ddd14bcf8818521e161bb118789175c4245b67a8ad5dd0cd3ef71f61d34d869e1c0c2a4a93 SHA512 3dbd465592fd98968b32e251659a70306a781999bcfa9e63e142d75d7c9274edc7cbe5069881e939f0e9472f0ef8580e4e0f20059bfc97f8c69893d86c8cadf3
DIST sogo-3.2.9.tar.gz 32443733 BLAKE2B 6a2ae4b5346bc48b9301263fe017308ee34aabcee1ce5444744b22c3af040533d98738fca29a195fd0f792d1d4470418840d0b1ff0e264c2ebc92877f420fa75 SHA512 070b3812d65598364d9204432678ea48705bf7481371e44442a13ad86d219415e24c579ad59212a7631922a527d30e69aeb17711c3abfc01960f663f4e0112a3
+DIST sogo-4.0.7.tar.gz 34455581 BLAKE2B 471ae8fc503fb2282cbd585286c0eede4e91e14bd9314a02089ffb0c69a8453538902cc26a4ebfdcacdce3d90f2d640221e1b452ad4b6a8064de89b1694eee7e SHA512 8e7eb946ab6ad8c47e6b612723675704602199b530c760ded5325f1230d89e7a812a61d9e652c7eca3050ed0bd0dd33d95faf2478f58a82dcba745cce4906675
diff --git a/gnustep-apps/sogo/metadata.xml b/gnustep-apps/sogo/metadata.xml
index 59f04d03a3a0..efbfee2b1c18 100644
--- a/gnustep-apps/sogo/metadata.xml
+++ b/gnustep-apps/sogo/metadata.xml
@@ -5,6 +5,9 @@
<email>gnustep@gentoo.org</email>
<name>Gentoo GNUstep Project</name>
</maintainer>
+ <use>
+ <flag name="activesync">Build the ActiveSync support code</flag>
+ </use>
<upstream>
<remote-id type="github">inverse-inc/sogo</remote-id>
</upstream>
diff --git a/gnustep-apps/sogo/sogo-4.0.7.ebuild b/gnustep-apps/sogo/sogo-4.0.7.ebuild
new file mode 100644
index 000000000000..874bd00ce788
--- /dev/null
+++ b/gnustep-apps/sogo/sogo-4.0.7.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnustep-2 user vcs-snapshot
+
+DESCRIPTION="Groupware server built around OpenGroupware.org and the SOPE application server"
+HOMEPAGE="http://www.sogo.nu"
+SRC_URI="https://github.com/inverse-inc/sogo/archive/SOGo-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="activesync gnutls libressl +ssl"
+
+RDEPEND="
+ dev-libs/libmemcached
+ net-misc/curl
+ net-misc/memcached
+ >=gnustep-libs/sope-${PV}[ldap]
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ >=gnustep-base/gnustep-make-2.6.3"
+
+pkg_pretend() {
+ if use ssl && use gnutls && use libressl ; then
+ ewarn "You have enabled both gnutls and libressl, but only"
+ ewarn "one provider can be active. Using gnutls!"
+ fi
+}
+
+pkg_setup() {
+ enewuser sogo -1 /bin/bash /var/lib/sogo
+}
+
+src_prepare() {
+ gnustep-base_src_prepare
+ sed -e "s/validateArgs$//" -i configure \
+ || die
+ if use activesync; then
+ sed -e '/^SUBPROJECTS =/a\\tActiveSync \\' \
+ -i GNUmakefile || die
+ fi
+
+ default
+}
+
+src_configure() {
+ local ssl_provider
+ if use ssl ; then
+ if use gnutls ; then
+ ssl_provider=gnutls
+ else
+ ssl_provider=ssl
+ fi
+ else
+ ssl_provider=none
+ fi
+
+ egnustep_env
+
+ ./configure \
+ --disable-strip \
+ --prefix=/usr \
+ --with-ssl="${ssl_provider}" \
+ $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ newconfd "${FILESDIR}"/sogod.confd sogod
+ newinitd "${FILESDIR}"/sogod.initd sogod
+
+ insinto /etc/logrotate.d
+ newins Scripts/logrotate sogo
+ newdoc Apache/SOGo.conf SOGo-Apache.conf
+
+ insinto /etc/sogo
+ doins Scripts/sogo.conf
+
+ insinto /etc/cron.d
+ newins Scripts/sogo.cron sogo
+ keepdir /var/log/sogo
+
+ fowners sogo:sogo /var/log/sogo
+ fowners -R root:sogo /etc/sogo
+}
+
+pkg_postinst() {
+ gnustep-base_pkg_postinst
+ elog "SOGo documentation is available online at:"
+ elog "http://www.sogo.nu/downloads/documentation.html"
+ elog
+ elog "Apache sample configuration file is available in:"
+ elog "/usr/share/doc/${PF}"
+ if use activesync; then
+ ewarn "In order to use the SOGo ActiveSync support code in production environments,"
+ ewarn "you need to get a proper usage license. Check the documentation for details."
+ fi
+}