summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/ffmpegthumbs/ffmpegthumbs-19.04.1.ebuild')
-rw-r--r--kde-apps/ffmpegthumbs/ffmpegthumbs-19.04.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-apps/ffmpegthumbs/ffmpegthumbs-19.04.1.ebuild b/kde-apps/ffmpegthumbs/ffmpegthumbs-19.04.1.ebuild
new file mode 100644
index 000000000000..f50e87594e08
--- /dev/null
+++ b/kde-apps/ffmpegthumbs/ffmpegthumbs-19.04.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="FFmpeg based thumbnail generator for video files"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="libav"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
+"
+RDEPEND="${DEPEND}"