summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/semantik/semantik-0.9.4-r1.ebuild')
-rw-r--r--kde-misc/semantik/semantik-0.9.4-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-misc/semantik/semantik-0.9.4-r1.ebuild b/kde-misc/semantik/semantik-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..56cb80395371
--- /dev/null
+++ b/kde-misc/semantik/semantik-0.9.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_REQUIRED="never"
+NO_WAF_LIBDIR="true"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+inherit python-single-r1 kde4-base waf-utils
+
+DESCRIPTION="Mindmapping-like tool for document generation"
+HOMEPAGE="http://freehackers.org/~tnagy/semantik.html https://code.google.com/p/semantik/"
+SRC_URI="http://ftp.waf.io/pub/release/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ dev-qt/qtwebkit:4
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README TODO )
+PATCHES=( "${FILESDIR}"/${PN}-0.9.0-wscript_ldconfig.patch )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}