summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/breeze-gtk/breeze-gtk-5.15.4.ebuild')
-rw-r--r--kde-plasma/breeze-gtk/breeze-gtk-5.15.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-plasma/breeze-gtk/breeze-gtk-5.15.4.ebuild b/kde-plasma/breeze-gtk/breeze-gtk-5.15.4.ebuild
new file mode 100644
index 000000000000..3e90156692c1
--- /dev/null
+++ b/kde-plasma/breeze-gtk/breeze-gtk-5.15.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit kde5 python-any-r1
+
+DESCRIPTION="Official GTK+ port of Plasma's Breeze widget style"
+HOMEPAGE="https://cgit.kde.org/breeze-gtk.git"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ $(add_plasma_dep breeze)
+ $(python_gen_any_dep 'dev-python/pycairo[${PYTHON_USEDEP}]')
+ dev-lang/sassc
+"
+
+python_check_deps() {
+ has_version "dev-python/pycairo[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ kde5_pkg_setup
+}