summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/breeze-gtk/breeze-gtk-5.25.4.ebuild')
-rw-r--r--kde-plasma/breeze-gtk/breeze-gtk-5.25.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/breeze-gtk/breeze-gtk-5.25.4.ebuild b/kde-plasma/breeze-gtk/breeze-gtk-5.25.4.ebuild
new file mode 100644
index 000000000000..0ae80b7ef65c
--- /dev/null
+++ b/kde-plasma/breeze-gtk/breeze-gtk-5.25.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-3)
+PYTHON_COMPAT=( python3_{8..11} )
+inherit ecm plasma.kde.org python-any-r1
+
+DESCRIPTION="Official GTK+ port of Plasma's Breeze widget style"
+HOMEPAGE="https://invent.kde.org/plasma/breeze-gtk"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/sassc
+ $(python_gen_any_dep 'dev-python/pycairo[${PYTHON_USEDEP}]')
+ >=kde-plasma/breeze-${PVCUT}:5
+"
+
+python_check_deps() {
+ python_has_version "dev-python/pycairo[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ ecm_src_configure
+}