summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.9.5.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 55a54238364c..d85fd2b5a5db 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 SHA256 0afc3eca084c327f8059166b86769f03c9c23e1e765bb47dc3229505abbac0c6 SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48 WHIRLPOOL e161bf40c5e16180fa65217cb49314fb230c45329f4c518d6014083bd71da82d4aa048811ee814fde7fa300105cef16c182688445164ae84d0d700e23641b342
DIST kinfocenter-5.8.6.tar.xz 1269552 SHA256 8bcc2438efb20106c9f0c8cae3a66ff202f71bf9acaaab940ffaf816002c10b5 SHA512 8eed4a548d782e0a29b9ce372b30ab250b619491dfa9efa73d3ec463cc43bb916a36702c949a4d6d25dfb7d4c350c84ebec08af7722a3a3ae5a37b2d9fca57cf WHIRLPOOL ffeeb1541e7eda54fc577d6c134fde491f8aef2d40e94615ad917d26705e72ca7a5b2a28771a823cbc273835f8c98ce45d93d58b8b57fa5dcdd47e3506eb2196
DIST kinfocenter-5.9.4.tar.xz 1266360 SHA256 9d30cd53d52df8cc83f950e501ae649651eb47e450abfe0453260750f4116e93 SHA512 2ba41d26fa63dbe983e0713a44e00016f83c253628b4acd42357cffd98e2998999047dab1510816a684e32e8059f80d063edbb6ae2fcb96a7f7f9b42b503f2b8 WHIRLPOOL 195a83d0feb98560bda3a21a3d9b520e15107814b1e0f262de27d41eeb92c646a9615edc98921cc18971dea2e79c7f2d38f88d83d60d557c7da149404bdcc4d9
+DIST kinfocenter-5.9.5.tar.xz 1269960 SHA256 4f6f37b29e9f29850389fec2708dd7733051095e0ff9b842327d73bc151e7149 SHA512 ac8e6fcc159769c97f25ca2d6d741023256f597d564ec9b5d182a24a7f73bbe53e380834c696408d6201e5612d3568a145b9ecef2eaf6b0bd5a7ff319a5d5f44 WHIRLPOOL e7b76ae030c5d84df0aa97e39e40d3279515c8c9be7c690d975321016a7c186574c5ac86804fbbaad49fa32ce24aa6d49efe7e4bd4e1901cfe121b22974fd832
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.9.5.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.9.5.ebuild
new file mode 100644
index 000000000000..511fefc267f0
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.9.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-apps/kcontrol:4
+ !kde-misc/about-distro
+ !kde-plasma/kinfocenter:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gles2 OpenGLES)
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ einfo "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba" || ! has_version "net-fs/samba[server]"; then
+ einfo "Installing net-fs/samba[server(+)] will enable the Samba status information module."
+ fi
+}