summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.11.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 63a7ada042f8..da7c7bd949f5 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1 +1,2 @@
DIST ksysguard-5.10.5.tar.xz 486420 SHA256 16cba11ec6f046f2d9587c84a1046af3fedd8b9d8d773ad8a90ff824ba029f7b SHA512 ce94cca9a0b2b68355a650d0355d243c02ab0b551add1d4fd779e8baae90e2110d72e204c9515031d1faf028f4cdb752fa351e7404b7df356d65a2b37bc8856c WHIRLPOOL ccf751b34c8e15ef5cdd3d204760e795a91781ac3abe6a67ac67203e97837dfec1c9c2dfd74266ac146bbad9158829ea1ed97f67aea1e44dd4bad5b48b924d15
+DIST ksysguard-5.11.0.tar.xz 488208 SHA256 f2f465d7310910774bb7ce2dd21ee17261f2768faffc448046b9d2f7484a737a SHA512 8c72c79e1183289f9f56b5afe5838d75fd568d3d112108467525909ded31e073e3dca987234a6d4779804f5af8123554847cc9ad40508c668bb484686214c550 WHIRLPOOL 110d703f299f63b3b89bd85959ec4eac70a246d5ffd1c5ec0069b26cb9d8faed72e3b340d9fbaa717424dd336baf25e4a90f397c869215c4fb596a6e4b1ceeb2
diff --git a/kde-plasma/ksysguard/ksysguard-5.11.0.ebuild b/kde-plasma/ksysguard/ksysguard-5.11.0.ebuild
new file mode 100644
index 000000000000..c7d1ee803356
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.11.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}