summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-browser-integration/plasma-browser-integration-5.16.5.ebuild')
-rw-r--r--kde-plasma/plasma-browser-integration/plasma-browser-integration-5.16.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.16.5.ebuild b/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.16.5.ebuild
new file mode 100644
index 000000000000..a07f080cec11
--- /dev/null
+++ b/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.16.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Integrate Chrome/Firefox better into Plasma through browser extensions"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep krunner)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMOZILLA_DIR="${EPREFIX}/usr/$(get_libdir)/mozilla"
+ )
+
+ kde5_src_configure
+}