summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.10.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index bb3c6cb3bd05..f1088ed68094 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.10.3.tar.xz 51760 SHA256 b6387a7fab2224307d63dad3bc0dedb12e17443ce79c02f383263389f7e7efee SHA512 8d113db8ab538c3fe38bfadee14cb4706bc0d3172511d88d5f0d08555920ad7cbbf9e26f4ea46b2f69b0f42611c8d6651f3efe589db9b802ee4da227b5d68ef2 WHIRLPOOL 5fa19021244960656f5ab3be57c921885059b2e7b5996e41d0b6281dcbcac2a8db35884dfd13afd5a649e65fb758c213ed8b91d20ad534824e9ad22c525ebf18
+DIST plasma-integration-5.10.4.tar.xz 51588 SHA256 068b4ed0b1160a78a336085f8b0bb192cd3c136f8a6a091f8ac7c593b207c565 SHA512 1aa6dbbbaae8f999f1898614afdfe32739a824404bc68f6e421c848f295e690019dd6cc9ca2f96dea021bd92653852fa9dd3be7b27ae35428d6927a523643f51 WHIRLPOOL 71f3ee95bda050b10fa5e92dd11f000497a7101b9bcc88ceb7153a41b6cdcb321d8ded445379d25a433379851c52ee04cf1e6013bf25ab479240e526c9f7ede8
DIST plasma-integration-5.9.5.tar.xz 49688 SHA256 1c84fdf4bd2d285485d0703248d3ae502443737f0cbc9870171560e872ce1d17 SHA512 5e69fb375b83cdc28230b9f1ff4a09ae2cdae3614ba2b7ab971d3d1666616eb7444c68e0065be927e8616c08a773f0b36ed9913f61066094a7a65f65174a8988 WHIRLPOOL 3d3a705ca1f00de7ed152adc6aed9d100b175027d0c874a40e521bf97a78a4f13c8d779235c6b86796f8f13a3516a8c31f02bdcdb5609019f038f385528fcb69
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.10.4.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.10.4.ebuild
new file mode 100644
index 000000000000..e50dd6194fb0
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.10.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"