summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.8.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 8c7f886d8260..2ea0b0c7ff3d 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.7.5.tar.xz 49240 SHA256 d41abdc63832d3fa1489aaec93dd382bb66e056982e3c49824f808f917f3ce16 SHA512 67b6b33e24b5e87b80694c7edd7d4daab8838f54a04922913c4138d55d02501d2dfe43c2718cdee4220dd194c424e50c83b711be5ee259ed58660b6c29d9e97f WHIRLPOOL 60d16269ea3ad267050c09337064ee25d98038314a5d007747cbf5970571f7c6cc6baeb1383e675ac741268133ce48a404d9f399d0dbf343aa57148444658728
DIST plasma-integration-5.8.2.tar.xz 50260 SHA256 2e13ec9fc4fd9d61e0328fb96218d42462ed79ca04134e760c4c517a6469f7fc SHA512 40ac0937f65df731a29a2173c2ebf4d15fd2ca9e370d2af5d3b44a3366ea2d9a4e217a404a9cd2f7d9aa75d33afa021eb9acf9be1769ef47f60d4deb13ed40f7 WHIRLPOOL 8e325603d3c2f65dc5dc50a949ca463ad4effcd48af42ec76ee2e62c8ab0dc97e5eae84825be360c88f699bd718289a76381e57d734ed868b577254026d2227f
+DIST plasma-integration-5.8.3.tar.xz 50640 SHA256 437cfef7c1a7de3b422e7003850025355a759d50514cfcb6cab2e5e5aaefcfa4 SHA512 25fe61c4d9884025f3c366072d5092bd57b8faba64bbe7045c8ef8f52e07375f1d88e2ae6598c48372ec455c14dd9b42ed3392e7427b41bd38e3f05a19753da8 WHIRLPOOL 69f1ca042518240f96172e0e363b329d55ef9e04d7aaba648ff54763521ab3b9b642791abd78b97b81991617a337e88923cf494fa2bc7afd1d28c107e0214175
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.8.3.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.8.3.ebuild
new file mode 100644
index 000000000000..2805c9b63a61
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.8.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"