summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.12.4.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index bb7b89590624..a67c42124373 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.11.5.tar.xz 718500 BLAKE2B bdd9520cfa3a305f7f2c271fdfc9678b43ed46e160ff7c7485a963889b32e60f56408bcc39b4fce81e570ce194410730a628bb2eb96afcfba8704b787d90c05a SHA512 6bc42e9b385fff03d994d66fb2088ce22b2766588c655466e4e26a0b57f1533c142ce7712c9182d9003368f30086333ea9670bac54b9b797e58a968f8bfc3512
DIST plasma-nm-5.12.3.tar.xz 703716 BLAKE2B a9335bb14dbbeda0b61a7ead5746afa003d55057e6435ff98923ec130a1a09846750a284309a66656d0589d8566302be397a9d08cafca75f5f058903c7e73d49 SHA512 30d9f9661df1b1f51502825e5a584126c4b6bca04f39cd24870b21dc92c46e3a60f218e03ce33365b7486067eaa6b1040a034d13a0e65de2095bc6463c82be9d
+DIST plasma-nm-5.12.4.tar.xz 703984 BLAKE2B 88e1e6ee4f69a3d6fcf5edf8f97d5a7146339de2b085233b0a94ed6950824bb2e85f6b98231873da501bedb609b65e3a7965d2dcd4903a6cc69c2075c269ea91 SHA512 f35ad6e833bc995230703c4d94a4a3e1e418472828f2ad43565fed5eb91792c714dec7712a3ce5e5fbdab45ee495f60e21f83d9d211d183b2b53278a0f8c336e
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.12.4.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.12.4.ebuild
new file mode 100644
index 000000000000..a699afd24882
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.12.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ >=net-misc/networkmanager-0.9.10.0[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/plasma-nm:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package modemmanager ModemManager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ einfo "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ einfo "However, the networkmanagement KCM can be called from either systemsettings"
+ einfo "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}