summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plymouth-kcm/plymouth-kcm-5.17.5.ebuild')
-rw-r--r--kde-plasma/plymouth-kcm/plymouth-kcm-5.17.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-plasma/plymouth-kcm/plymouth-kcm-5.17.5.ebuild b/kde-plasma/plymouth-kcm/plymouth-kcm-5.17.5.ebuild
new file mode 100644
index 000000000000..6a65a50a3e04
--- /dev/null
+++ b/kde-plasma/plymouth-kcm/plymouth-kcm-5.17.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+BOGUS=1
+KFMIN=5.64.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="KDE Plasma control module for Plymouth"
+HOMEPAGE="https://cgit.kde.org/plymouth-kcm.git"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ sys-boot/plymouth
+"
+RDEPEND="${DEPEND}
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"
+
+DOCS=( CONTRIBUTORS )